This page lists incidents by Namespace and known upstream issues.
Resolved
We're seeing delays from GitHub going down, and almost all jobs are now starting without increased latency.
Identified
We continue to see delayed webhook deliveries from GitHub, and they're now tracking this at https://www.githubstatus.com/incidents/67w72l5v25x3
Identified
We're seeing delayed webhook deliveries from GitHub, resulting in increased queue time for a subset of jobs.