This page lists incidents by Namespace and known upstream issues.
Resolved
We applied a mitigation to prioritize a different issuer, certificate issuing has recovered.
Identified
We're seeing a subset of certificates for Preview environments failing to be issued, we're working on mitigation.