This page lists incidents by Namespace and known upstream issues.
No components marked as affected
Resolved
We see no more networking interruptions, all systems are operational.
Monitoring
We switched all traffic in our Europe region to a different transit provider to force different routing.
Identified
We identified degraded connectivity for some routes between Europe and the US, starting 7:58 UTC.