Resolved
All systems are operational - queue times are back to normal levels.
Identified
We are observing an elevated queue time for a subset of GitHub runners.
The team is working towards a mitigation.
This page lists incidents by Namespace and known upstream issues.