Resolved
Webhook delivery times are back to normal levels
Monitoring
GitHub Webhook delivery times are improving but still above normal levels, we'll continue to monitor for improvement.
Investigating
A delay in job notifications is causing increased queue times for a subset of jobs. Delayed webhook delivery indicates a possible problem on GitHub's side. We're monitoring the situation and investigating any possible cause on our side.