Small set of Github Runners not acquiring jobs
Resolved·Degraded performance

Complete recovery has been verified.

Thu, Sep 4, 2025, 12:47 AM
(2 days ago)
·
Affected components
Updates

Resolved

Complete recovery has been verified.

Thu, Sep 4, 2025, 12:47 AM

Monitoring

The issue was caused by degraded performance from one of our upstream network providers. The team rolled out a mitigation and all jobs have been picked up and queue time is back to normal values.

Thu, Sep 4, 2025, 12:45 AM

Investigating

We are observing some Github Runners not acquiring jobs leading to elevated queue time. We are investigating.

Thu, Sep 4, 2025, 12:20 AM(24 minutes earlier)