Ubuntu's package archives report outage affecting some Docker builds
Resolved

We're seeing full recovery of Ubuntu's Archives

Wed, Sep 3, 2025, 10:27 AM
(3 days ago)
·
Affected components

No components marked as affected

Updates

Resolved

We're seeing full recovery of Ubuntu's Archives

Wed, Sep 3, 2025, 10:27 AM

Monitoring

Canonical has resolved their incident and we are seeing successful connections to the archives.

We'll continue to monitor to validate a full recovery.

Wed, Sep 3, 2025, 10:21 AM

Investigating

Canonical is reporting an outage of Ubuntu's package archives, and our team has confirmed some workloads are unable to reach them. We'll continue to monitor availability and update this incident if the situation improves.

Workloads running on GitHub Actions are automatically rerouted to different mirrors.

Some Docker builds using Ubuntu base images are seeing degraded performance and errors.

A temporary workaround can be added to your Dockerfile until registries recover:

Ubuntu 22.04 and earlier:

RUN sed -i 's%http://\(archive\|security\).ubuntu.com/%http://azure.archive.ubuntu.com/%g' /etc/apt/sources.list

Ubuntu 24.04 and later:

RUN sed -i 's%http://\(archive\|security\).ubuntu.com/%http://azure.archive.ubuntu.com/%g' /etc/apt/sources.list.d/ubuntu.sources

We recommend undoing these changes once registries recover to remain aligned with base images.

Wed, Sep 3, 2025, 09:58 AM(22 minutes earlier)