Resolved
all runners are picking up with expected queue time levels.
Investigating
GitHub runners created between 09:05 UTC and 09:21 UTC are seeing a higher than usual queue time.
Jobs created before and after this point in time are picked up at the expected rate.