Resolved
The issue has been resolved by Github, all jobs recovered.
Identified
We are observing intermittent slowness for runners to pick up jobs. According to our investigation the issue lies on the GitHub side. We are monitoring the situation and looking into mitigations.
Investigating
We are observing some Github Runners not acquiring jobs leading to elevated queue time. We are investigating.