Ubuntu's package archives report outage affecting Docker builds
Resolved·Degraded performance

We've seen a full recovery and performance has returned to expected levels.

Wed, Jul 2, 2025, 04:02 PM
(4 days ago)
·
Affected components
Updates

Resolved

We've seen a full recovery and performance has returned to expected levels.

Wed, Jul 2, 2025, 04:02 PM

Monitoring

Canonical has reported the incident as resolved, and we are seeing successful builds using Ubuntu's archives.

We'll continue to monitor performance to verify a full recovery.

Wed, Jul 2, 2025, 02:53 PM(1 hour earlier)

Monitoring

Canonical is reporting an outage of Ubuntu's package archives, and our team has confirmed workloads are unable to reach them. We'll continue to monitor availability and update this incident if the situation improves.

Workloads running on GitHub Actions are automatically rerouted to different mirrors.

Docker builds using Ubuntu base images are seeing degraded performance and errors.

A temporary workaround can be added to your Dockerfile until registries recover:

Ubuntu 22.04 and earlier:

RUN sed -i 's%http://\(archive\|security\).ubuntu.com/%http://azure.archive.ubuntu.com/%g' /etc/apt/sources.list

Ubuntu 24.04 and later:

RUN sed -i 's%http://\(archive\|security\).ubuntu.com/%http://azure.archive.ubuntu.com/%g' /etc/apt/sources.list.d/ubuntu.sources

We recommend undoing these changes once registries recover to remain aligned with base images.

Wed, Jul 2, 2025, 02:15 PM(37 minutes earlier)