Resolved
We see full recovery across all customers. Instances are created again in the US (ord) compute shard.
Identified
We have identified the problem which caused instances not being able to be created in the US compute shard. A mitigration has been applied an we are actively monitoring instance creation and job ingestion.