We are investigating potential unavailability of GitHub Runners
Resolved·Partial outage

We confirm that all new GitHub jobs ingested by our systems are now processed correctly and their runners run the workload.

Tue, May 6, 2025, 08:09 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

We confirm that all new GitHub jobs ingested by our systems are now processed correctly and their runners run the workload.

Tue, May 6, 2025, 08:09 PM

Monitoring

An issue in one of our compute shards has been identified and a mitigation has been applied. We observe recovery for our customers and their recent jobs.

Tue, May 6, 2025, 08:03 PM

Investigating

Our telemetry alerted us of high queue time for GitHub Actions jobs. The team is investigating.

Tue, May 6, 2025, 07:47 PM(15 minutes earlier)