Resolved
All applications are operational.
We've started seeing recovery from our providers to access the compute shard impacted by the network partition. We'll restore the compute shart into our fleet as we get full recovery from our providers.
Monitoring
We completed the migration of customer workloads from the problematic region. GitHub jobs are not processed within the expected queue time.
The team is monitoring the systems and working in the background with our providers to restore access to the isolated region.
Identified
Our team identified a network partition that impacted a single compute region. We diverted customer workloads away from that region, and we see recovery of queue time for all customers.
The team is working now with our providers to restore access to the region.
Investigating
Out team got alerted for high queue time for GitHub Actions jobs. We are investigating.