We are investigating potential unavailability of GitHub Runners
Resolved·Partial outage

We confirm that all new GitHub jobs ingested by our systems are now processed correctly and their runners run the workload.

Mon, Apr 14, 2025, 08:52 PM
(1 week ago)
·
Affected components
Updates

Resolved

We confirm that all new GitHub jobs ingested by our systems are now processed correctly and their runners run the workload.

Mon, Apr 14, 2025, 08:52 PM

Monitoring

We observe recovery for most of our customers and their recent jobs. GitHub jobs created between 19:46:22 and 20:00:00 UTC may still be impacted by GitHub's outage.

Mon, Apr 14, 2025, 08:33 PM(19 minutes earlier)

Investigating

Our telemetry alerted us of high queue time for GitHub Actions jobs. The team is investigating. We observe our runners getting created correctly and getting registered to GitHub backend services. However, we see these runners not getting selected for customers' jobs.

Mon, Apr 14, 2025, 08:12 PM(21 minutes earlier)