Resolved
The changes are live and queue time is back to normal levels.
Identified
We're seeing elevated queue time for MacOS GitHub runners.
We understand the cause and are rolling out a mitigation.
This page lists incidents by Namespace and known upstream issues.