Degraded upstream performance to US East (and more)
Resolved
Degraded performance

Our transit provider deployed mitigation and we're seeing recovery across the board.

Wed, Mar 12, 2025, 09:18 PM
5d ago
Affected components
Updates

Resolved

Our transit provider deployed mitigation and we're seeing recovery across the board.

Wed, Mar 12, 2025, 09:18 PM
30m earlier...

Identified

Jobs running in Europe are observing degraded network performance to US East.

We're working with our upstream network provider on mitigating this.

Wed, Mar 12, 2025, 08:47 PM