Potential delays in creation of GitHub Runners
Resolved
Degraded performance

The issue from upstream was transient, and new jobs were served within the expected queue time.

We'll keep monitoring our telemetry data.

Tue, Jan 7, 2025, 02:07 PM
2 weeks ago
Affected components
Updates

Resolved

The issue from upstream was transient, and new jobs were served within the expected queue time.

We'll keep monitoring our telemetry data.

Tue, Jan 7, 2025, 02:07 PM

Monitoring

Our investigation revealed that GitHub systems report a few jobs with inconsistent data. Our alerting rules estimated higher queueing time based on these wrong data.

We believe that all jobs were processed just fine. We also confirm that newer jobs are processed and report correct data.

Our team will keep monitoring the situation.

Tue, Jan 7, 2025, 02:05 PM
16m earlier...

Investigating

Our telemetry alerted us of potential delays in creating new instances to server GitHub Actions jobs. Our team is investigating.

Tue, Jan 7, 2025, 01:49 PM